解决只能lan口访问,不能wan口访问硬盘资源的问题。

1、小米路由器要开启ssh
2、ssh到小米路由器,编辑/etc/samba/smb.conf.template 文件,将其中的interfaces那一行改为

?
1
interfaces = br-lan eth0.2
3、编辑/etc/config/firewall文件,在文件最后添加以下内容:

?
1
2
3
4
5
6
7
8
9
10
11
12
13
config rule 'samba_udp'

    option src 'wan'                    
    option dest_port '137 138'             
    option proto 'udp'                                  
    option target 'ACCEPT'                  
    option name 'samba_incoming_udp'

config rule 'samba_tcp'

    option src 'wan'                                   
    option dest_port '139 445'            
    option proto 'tcp'                
    option target 'ACCEPT'                 
    option name 'samba_incoming_tcp'

4、执行/etc/init.d/samba restart命令重启samba服务
5、执行/etc/init.d/firewall restart命令重启防火墙

用\xxx.xxx.xxx.xxx 访问试试。xxx是小米路由器的wan ip地址

最后修改:2021 年 07 月 09 日 09 : 32 PM
如果觉得我的文章对你有用,请随意赞赏